Article | Roland
Knowledge Base Article

cutstudio

Title
CutStudio Updater
Symptom
Roland CutStudio Updater to Ver.3.10
Cause
​[Model] : SV-8, SV-12, SV-15, GX-300, GX-400, GX-500, GX-640, GX-24, GS-24, GR-640/540/420
[OS] : Windows7(32-bit/64-bit)/8(32-bit/64-bit)/8.1(32-bit/64-bit)/10(32-bit/64-bit)
Solution
​This is updating program to the latest version.
You need to have Roland CutStudio already installed.
Download the exe file, and extract it, then, click "updater.exe" to follow the instruction as displayed. Please refer to "readme.txt" in the extracted folder.

CutStudio_ver310.zip (10.6MB) DOWNLOAD
Applies To
CutStudio, GX-24, GX-300, GX-400, GX-500, GX-640
Modified
October 29, 2018